Webinary

Aktualizacja PHP kluczem do lepszego działania Twojej strony www – odpowiadamy na pytania z webinaru

Za nami kolejny webinar organizowany przez home.pl w ramach Akademii home.pl.
Poruszony został temat aktualizacji PHP stron internetowych.
Poniżej publikujemy odpowiedzi na zadane w czasie webinaru pytania.

Co mogę zrobić, gdy moje strony nie działają na żadnym pHP oprócz 5.4?

W przypadku gdy strony działają tylko w PHP w jakiejś wersji, to oznacza, że kod jest niezgodny z kolejnymi wersjami. Dlatego wcześniej trzeba usunąć niekompatybilność, żeby przejść na następną wersję.

Nie ma uniwersalnej odpowiedzi co zrobić, bo za każdym razem to wymaga analizy.

Pomocne bywają strony php.net, gdzie zmiany w każdej kolejnej wersji są szczegółowo opisane. Przykładowo przejście z PHP 5.4 do 5.5: https://www.php.net/manual/de/migration55.php. Przejście z wersji 5.4 (wydanie z marca 2012) do najnowszej (7.4, a za chwilę 8.0) to duże wyzwanie. Dlatego zalecana jest na przyszłość regularna aktualizacja wersji PHP, żeby nie zostać z tak dużymi zaległościami.

Aktualnie przygotowujemy aplikację, która będzie w przyszłości wskazywała konkretne linie w kodzie, które należy zmienić, żeby kod był zgodny z wybraną wersją PHP, co z pewnością znacznie uprości samodzielne dokonywanie poprawek.
Na ten moment można wspomóc się aplikacją rector, której zestawy reguł pomagają m.in. w migracji do nowszych wersji PHP.

Jeżeli jednak będą mieli Państwo problem z samodzielnym usunięciem niekompatybilności, wystarczy zgłosić się na naszą infolinię, gdzie specjalista poinformuje Państwa o usłudze dostosowania strony pod zmianę wersji PHP.

Czy korzystając z WordPressa z home.pl będę mogła liczyć na aktualizację PHP? Jeżeli tak, to czy jest to usługa płatna.

Oczywiście, zmiana wersji PHP przy używaniu WordPressa na hostingu czy jakiegokolwiek innego systemu do zarządzania treścią jest możliwa. Sam WordPress preferuje, aby jego strony działały właśnie na najnowszych wersjach PHP. Aktualizacja wersji PHP jest usługą całkowicie bezpłatną – zmiany można dokonać w prosty sposób poprzez Panel Klienta home.pl lub poprosić o nią, dzwoniąc na naszą infolinię.

Jeżeli jednak Państwa strona została zbudowana na bardzo starej wersji PHP, istnieje możliwość, że stronę będzie trzeba dostosować. Dostosowanie strony służy temu, aby wszystkie treści i grafiki wyświetlały się prawidłowo. Zmiana wersji PHP jest jednak konieczna, aby zachować bezpieczeństwo witryny.

home.pl oferuje usługę dostosowania strony do nowej wersji PHP, a nawet odświeżenia całej strony. Wtedy najlepiej jest skontaktować się z naszą infolinią i poprosić o przedstawienie usługi.

Co to znaczy, że haker może zdobyć moje dane? Może ukraść moją tożsamość ze strony lub moich klientów?

Posiadanie strony opartej o już niewspieraną wersję PHP w kwestii bezpieczeństwa nie spowoduje od razu, że dane zostaną skradzione. Nawet starsze rozwiązania spełniają pewne kryteria bezpieczeństwa, rozpoczynając od fizycznego zabezpieczenia serwerów oraz zabezpieczenia całego środowiska (co robimy w home.pl przygotowując hosting) oraz samej aplikacji. Zarówno twórcy aplikacji jak i twórcy PHP dbają o bezpieczeństwo, ważne jest jednak, aby dokonywać regularnych aktualizacji zarówno aplikacji jak i PHP. Brak aktualnej wersji PHP na serwerze zwiększa prawdopodobieństwo włamania na stronę i kradzież danych. Skradzione mogą zostać dane użytkowników lub właściciela witryny i nie jest wykluczone, że mogą te posłużyć nawet do kradzieży tożsamości i wyłudzeń.

Zapraszamy do udziału w kolejnych webinarach Akademii home.pl

Dodaj komentarz